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MDM Profile on iOS 15/iPadOS 15 and macOS 12 devices shows as “Not Verified” or “Unverified”

Applicable Products

  • Citrix Endpoint Management

Symptoms or Error

Current enrolled devices that were upgraded fromiOS 14/iPadOS 14 or earlierto iOS/iPadOS 15 or newly enrolled devices on iOS/iPadOS 15 may show “Not Verified” under the device “Settings > General > VPN & device Management > Citrix Workspace MDM Profile”
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Current enrolled devices that were upgraded frommacOS 11 or earlierto macOS 12 or newly enrolled devices on macOS 12 may show “Not Verified” under the “macOS System Preferences > Profile > Citrix Workspace MDM Profile”
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Solution

Please note, there is no change to functionality or security with this change.

End-users can maintain the “Verified” display of their enrollment profile by re-enrolling either prior to the new iOS/iPadOS or macOS versions, or after upgrading to iOS 15/iPadOS 15 or macOS 12, through which the user will receive a new enrollment profile signed with Citrix’s public CA.

Citrix has made changes to support to iOS 15/iPadOS 15 or macOS 12, such that new MDM enrollment profiles are signed with Citrix’s public CA and will display as “Verified”, any prior enrollments signed with Citrix’s private CA showing as “Verified” on iOS 14/iPadOS 14 or macOS 11 or earlier, will show as “Not Verified” or “Unverified” once the device is updated to iOS 15/iPadOS 15 or macOS 12 is updated.



Problem Cause

Apple has made changes to the verification of MDM enrollment profiles, whereby starting in iOS 15/iPadOS 15 and macOS 12, only profiles signed with public CAs are displayed as “Verified”. Private CAs, such as those used by Citrix, will now display as “Not Verified” or “Unverifed” in iOS 15/iPads 15 and macOS 12.

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